Installare newLISP

newlisp-rockets-pictureCome installare newLISP su Ubuntu 64 bits. Forse lo sanno tutti, o forse no –io per esempio.

newLISP rockz! è risaputo.
Ma a volte, come ho verificato in questi giorni, l’installazione normale non funziona, da errore “file o directory non esistente“. Panico?
No, niente panico, proprio come c’è scritto sulla copertina della Guida (grande libro, fondamentale, l’unico che serve davvero).

Nel caso specifico dopo aver fatto qualche tentativo per capire cos’era che mancava e aver mandato una richiesta d’aiuto a Lutz sono ricorso a G+. Trovato quasi subito. Qui: How to compile newLISP from source on 64-bit Ubuntu.

Funziona. Notare che:

  • il post è vecchio di 18 mesi;
  • il blog è operato da newLISP;
  • la versione corrente è la 10-6.0 e non quella indicata nel post.

eniac4

OK, caso risolto. Se avete un momento libero date una scorsa qui: Why newLISP on Rockets?

Ve l’ho già detto che newLISP rockz? Rocket Man too, nèh!

Posta un commento o usa questo indirizzo per il trackback.

Commenti

  • ucasano  Il 8 novembre 2014 alle 11:22

    Volevo solo segnalare agli interessati che per compilare newLisp 10.6.0 dai sorgenti è necessario avere a disposizione sulla propria macchina una versione di libreadline inferiore alle 6.3.

    Per “forzare” comunque la compilazione, è sufficiente rimuovere dal Makefile del proprio sistema la dicitura “-DREADLINE”; in alternativa è possibile correggere i sorgenti sostituendo le funzioni deprecate e ormai non più disponibili (CPPFunction, CPFunction…), oppure attendere una nuova release che supporti readline 6.3.

    la versione di sviluppo 10.6.2 presenta ancora lo stesso problema.

    Spero di essere stato utile.
    -g

    • juhan  Il 8 novembre 2014 alle 11:30

      Ho compilato senza problemi e mi sembra tutto OK. Ma forse mi sta sfuggendo qualcosa 😦

      • ucasano  Il 8 novembre 2014 alle 11:58

        la tua versione di readline? 6.2?

      • juhan  Il 8 novembre 2014 alle 12:06

        Sai che non lo so! Ho solo seguito le procedure indicate nel post di Rocket Man.

  • ucasano  Il 9 novembre 2014 alle 17:29

    Nessun problema: se stai usando Ubuntu 12.04 o inferiori la versione della readline è <= 6.2; su Ubuntu 14.04 la readline è la 6.3!

    Il mio post era rivolto proprio agli utilizzatori di Ubuntu 14.04, che non sarebbero riusciti a compilare proprio a causa della readline 6.3.

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo di WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione /  Modifica )

Google photo

Stai commentando usando il tuo account Google. Chiudi sessione /  Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione /  Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione /  Modifica )

Connessione a %s...

Questo sito utilizza Akismet per ridurre lo spam. Scopri come vengono elaborati i dati derivati dai commenti.

%d blogger hanno fatto clic su Mi Piace per questo: